app-blacklist-check

Discussion in 'General' started by Zach, Dec 4, 2008.

  1. Zach

    Joined:
    Sep 11, 2008
    Messages:
    31
    Likes Received:
    0
    Hi,

    I would like to know which file is lauch to check the blacklist database. When I receive a call my asterisk doesn't check the blacklist database.

    When I receive a call I should see something like this in the first lines :

    Verbosity is at least 5
    -- Accepting voice call from '55512345' to '4001' on channel 0/1, span 1
    -- Executing Set("Zap/1-1", "__FROM_DID=74") in new stack
    -- Executing Gosub("Zap/1-1", "app-blacklist-check|s|1") in new stack
    -- Executing LookupBlacklist("Zap/1-1", "") in new stack
    -- Executing GotoIf("Zap/1-1", "0?blacklisted") in new stack

    This is what I have instead of :


    Executing [4001@from-pstn:1] Macro("XOIP/g0-0x228508", "exten-vm|novm|4001") in new stack
    -- Executing [s@macro-exten-vm:1] Macro("XOIP/g0-0x228508", "user-callerid") in new stack
    -- Executing [s@macro-user-callerid:1] NoOp("XOIP/g0-0x228508", "user-callerid: 55512345") in new stack
    -- Executing [s@macro-user-callerid:2] Set("XOIP/g0-0x228508", "AMPUSER=55512345") in new stack
    -- Executing [s@macro-user-callerid:3] GotoIf("XOIP/g0-0x228508", "0?report") in new stack
    -- Executing [s@macro-user-callerid:4] ExecIf("XOIP/g0-0x228508", "1|Set|REALCALLERIDNUM=55512345") in new stack
    -- Executing [s@macro-user-callerid:5] NoOp("XOIP/g0-0x228508", "REALCALLERIDNUM is 55512345") in new stack
    -- Executing [s@macro-user-callerid:6] Set("XOIP/g0-0x228508", "AMPUSER=") in new stack
    -- Executing [s@macro-user-callerid:7] Set("XOIP/g0-0x228508", "AMPUSERCIDNAME=") in new stack
    -- Executing [s@macro-user-callerid:8] GotoIf("XOIP/g0-0x228508", "1?report") in new stack
    -- Goto (macro-user-callerid,s,13)
    -- Executing [s@macro-user-callerid:13] NoOp("XOIP/g0-0x228508", "TTL: ARG1: novm") in new stack
    -- Executing [s@macro-user-callerid:14] GotoIf("XOIP/g0-0x228508", "0?continue") in new stack
    -- Executing [s@macro-user-callerid:15] Set("XOIP/g0-0x228508", "__TTL=64") in new stack
    -- Executing [s@macro-user-callerid:16] GotoIf("XOIP/g0-0x228508", "1?continue") in new stack
    -- Goto (macro-user-callerid,s,23)
    -- Executing [s@macro-user-callerid:23] NoOp("XOIP/g0-0x228508", "Using CallerID "" <55512345>") in new stack
    -- Executing [s@macro-exten-vm:2] Set("XOIP/g0-0x228508", "FROMCONTEXT=exten-vm") in new stack
    -- Executing [s@macro-exten-vm:3] Set("XOIP/g0-0x228508", "VMBOX=novm") in new stack
    -- Executing [s@macro-exten-vm:4] Set("XOIP/g0-0x228508", "EXTTOCALL=4001") in new stack
    -- Executing [s@macro-exten-vm:5] Set("XOIP/g0-0x228508", "CFUEXT=") in new stack
    -- Executing [s@macro-exten-vm:6] Set("XOIP/g0-0x228508", "CFBEXT=") in new stack
    -- Executing [s@macro-exten-vm:7] Set("XOIP/g0-0x228508", "RT=""") in new stack
    -- Executing [s@macro-exten-vm:8] Macro("XOIP/g0-0x228508", "record-enable|4001|IN") in new stack
    -- Executing [s@macro-record-enable:1] GotoIf("XOIP/g0-0x228508", "0?2:4") in new stack
    -- Goto (macro-record-enable,s,4)
    -- Executing [s@macro-record-enable:4] AGI("XOIP/g0-0x228508", "recordingcheck|20081204-114303|1228387383.85") in new stack
    -- Launched AGI Script /opt/var/lib/asterisk/agi-bin/recordingcheck
    recordingcheck|20081204-114303|1228387383.85: Inbound recording not enabled
    -- AGI Script recordingcheck completed, returning 0
    -- Executing [s@macro-record-enable:5] NoOp("XOIP/g0-0x228508", "No recording needed") in new stack
    -- Executing [s@macro-exten-vm:9] Macro("XOIP/g0-0x228508", "dial||tr|4001") in new stack
    -- Executing [s@macro-dial:1] GotoIf("XOIP/g0-0x228508", "1?dial") in new stack
    -- Goto (macro-dial,s,3)
    -- Executing [s@macro-dial:3] AGI("XOIP/g0-0x228508", "dialparties.agi") in new stack
    -- Launched AGI Script /opt/var/lib/asterisk/agi-bin/dialparties.agi
    dialparties.agi: Starting New Dialparties.agi
    == Parsing '/opt/etc/asterisk/manager.conf': Found
    == Parsing '/opt/etc/asterisk/manager_additional.conf': Found
    == Parsing '/opt/etc/asterisk/manager_custom.conf': Found
    == Manager 'admin' logged on from 127.0.0.1
    dialparties.agi: Caller ID name is 'unknown' number is '55512345'
    dialparties.agi: USE_CONFIRMATION: 'FALSE'
    dialparties.agi: RINGGROUP_INDEX: ''
    dialparties.agi: Methodology of ring is 'none'
    -- dialparties.agi: Added extension 4001 to extension map
    -- dialparties.agi: Extension 4001 cf is disabled
    -- dialparties.agi: Extension 4001 do not disturb is disabled
    > dialparties.agi: extnum 4001 has: cw: 1; hascfb: 0 [] hascfu: 0 []
    > dialparties.agi: ExtensionState: 0
    -- dialparties.agi: dbset CALLTRACE/4001 to 55512345
    -- dialparties.agi: Filtered ARG3: 4001
    == Manager 'admin' logged off from 127.0.0.1
    -- AGI Script dialparties.agi completed, returning 0
    -- Executing [s@macro-dial:7] Dial("XOIP/g0-0x228508", "SIP/4001||tr") in new stack
    -- Called 4001
    -- SIP/4001-40e14fa8 is ringing





    Can somebody help me ?

    thanks
     
  2. mfdukn

    Joined:
    Sep 10, 2007
    Messages:
    16
    Likes Received:
    0
    Hello!
    I have the same problem(Elastix1.3). And exactly the same log. Can somebody explane how blacklist works? When i type in GUI the number that i want to be blacklisted, nothing happens. It can make incoming calls.
    But if i type manually some dialplan like this:

    exten => 4,n,LookupBlacklist()
    exten => 4,n,GotoIf($["${LOOKUPBLSTATUS}"="FOUND"]?blacklisted)
    exten => 4,n,Ringing()
    exten => 4,n,Goto(ext-group,601,1)
    exten => 4,n,HangUp()
    exten => 4,n(blacklisted),Answer
    exten => 4,n,Wait(1)
    exten => 4,n,Playback(forbidden)
    exten => 4,n,Wait(1)
    exten => 4,n,Hangup

    than it works!

    what i'm doing wrong?
    Please help

    Why we can see blacklist only in freePBX unembedded, but not in Elastix?
     
  3. mfdukn

    Joined:
    Sep 10, 2007
    Messages:
    16
    Likes Received:
    0
    Blacklist works undependable of caller-id length
    if blacklisted number is identical with caller-id, it works in manual dial-plan. But does-not work in dial-plan, created by GUI!

    PS Zash! Did you resolve this problem?
     

Share This Page