answeronpolarityswitch=yes NO RINGBACK

Discussion in 'Elastix 2.x' started by joe72lp, Oct 21, 2010.

  1. joe72lp

    Joined:
    May 4, 2010
    Messages:
    6
    Likes Received:
    0
    Hola, he hecho una instalacion nueva de la version 2.0.0-36 64 Bits, y me encontre con la desagradable sorpresa que ahora por la tarjeta TDM400 4FXO no escucho el RINGBACK hasta que la llamada es atendida. Claro eso siempre y cuando se atienda ya que si atiende una contestadora no se escucha el audio lo cual es gravisimo.

    Esto esta afecta por el answeronpolarityswitch=yes, poniendolo en no el canal de audio abre logicamente porque la llamada la toma como atendida.

    Estuve buscando info de este problema pero no hay ninguna solucion.

    Alguien pudo solucionarlo??.


    Gracias
     
  2. hugo_cba

    Joined:
    May 22, 2008
    Messages:
    222
    Likes Received:
    0
    La verdad es que nunca tuve ese problema...

    En que país estás? Consultaste con la telco que señalización utiliza para líneas analógicas? Loop Start o ground start?

    answeronpolarityswitch=yes en que archivo lo tenés a esta línea? en chan_dahdi?
    Hacé la prueba de borrar esa línea...

    Por otro lado, verificá en el menú PBX>>>Configuración general que opciones tenés en ASterisk Dial command Options y en Asterisk Outbound Dial command Options, yo tengo configurado "tr" en Asterisk dial command options.

    Espero tus respuestas para seguir avanzando sobre tu problema!
     
  3. joe72lp

    Joined:
    May 4, 2010
    Messages:
    6
    Likes Received:
    0
    Hola Gracias por la respuesta.
    Si elimino esa linea por supuesto que funciona, ya que no se espera mas la inversion de polaridad para tomar como atendida la llamada. No es un problema de proveedor de telefonia ya que cuando uno habilita la inversion de polaridad para detectar que el abonado B atendió el canal de audio debe estar siempre abierto, por ej , cuando tu llamas a un celular la reversa de polaridad viene luego del BEEP de "LUEGO DEL TO NO DEJE SU MENSAJE....BEEP".

    En la version 1.6 no sucede este problema, y aqui hay otro usuario que tambien tiene el mismo problema con esto en la vrsion de 64 bits. Todavia no probe si en la de 32 hace lo mismo.

    En las opciones tengo tr SOLO en Dial Commands Options.

    Algunos enlaces que comentan lo mismo

    http://www.freepbx.org/forum/freepbx/us ... -back-tone

    http://www.elastix.org/en/component/kun ... x-202.html

    Gracias
     
  4. zeoneo

    Joined:
    Sep 24, 2009
    Messages:
    549
    Likes Received:
    0
    es muy interezante esto ya que las TDM funcionan casi igual que los SPA...

    yo he estado experimitando problemas con mi elastix 2.0 con este mismo problema..

    Si encuentras la solucion porfavor comunicala.

    Nos vemos
     
  5. joe72lp

    Joined:
    May 4, 2010
    Messages:
    6
    Likes Received:
    0
    La solucion fue volver a la 1.6.
    En la 2 encontre demasiados errores como para que sea un version funcional en un ambiente productivo.

    Saludos
     
  6. manzurek

    Joined:
    Jun 22, 2007
    Messages:
    194
    Likes Received:
    0
    Solucion:
    En sip.conf
    progressinband=yes
    prematuremedia=no
     

Share This Page