Anonymous calls

Discussion in 'General' started by grant84, Feb 24, 2009.

  1. grant84

    Joined:
    Jan 13, 2009
    Messages:
    5
    Likes Received:
    0
    Hi guys,

    Had my elastix server running for a few months now, i've noticed a few anonymous calls in the logs that have gone to a destination but never got the voice mail. Most likely telemarketers.

    So i thought i'd double check it, i have anonymous calls enabled in general settings.

    I dialed the prefix before calling my number to make it hidden, i got to the IVR selected an option but it went straight to voicemail and didn't ring the extension. Yet if i do the same showing the phone number it works.

    Any ideas what could be causing this?
     
  2. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    The "Allow Anonymous Inbound SIP Calls?" in the general settings have nothing to do with Caller ID blocked calls. Basically that setting is to set whether your system will accept incoming SIP calls from places that don't match any of your known SIP registrations (generally speaking, they aren't coming in via one of your SIP trunks). There are reasons to allow or disallow these (which are debated in other threads) but that setting is not what is causing the problem you are seeing.

    Maybe you have the Privacy Manager turned on in an incoming route but for some reason it's not working as it should. Maybe you have Call Screening turned on for the individual extension but again it's not working as you'd expect. Or maybe (more likely) the endpoint (phone or adapter) has its own call screening feature - perhaps it rejects calls not showing a valid Caller ID, so when it rejects Asterisk does the only thing it can with the call, which is to send it to voicemail. This might be toggled by a feature code, or by a setting accessed via the web-based interface for the phone or adapter.

    You should look at the CLI output during an incoming call and/or the Asterisk log file to see if you can see any reason the call is being shunted off to voicemail.
     
  3. grant84

    Joined:
    Jan 13, 2009
    Messages:
    5
    Likes Received:
    0
    Hi,

    Thanks for that.

    The phone is a Linksys SPA942 i have 3 extensions setup on it from elastix. Looked through all the settings on the phone can't find anything. In the phone call log it doesn't get the anonymous calls at all.

    No privacy manager configured I followed the Elastix without tears guide.

    Ok looked through the log and found this.
    Got SIP response 406 "Not Acceptable" back from (IP this is phone)
    VERBOSE [2240] logger.c: -- No one is available to answer at this time (1:0/0/0

    what setting would it be called on the linksys phone, they have very confusing menus.

    thanks for your help
     
  4. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    No fooling. Under each "User" tab, in the Supplementary Service Settings, look at the "Block ANC Setting" - it should be set to No. If it isn't, change it and save the settings.

    Then to prevent it from being accidentally reactivated, go to each "Line" tab, look for the "Supplementary Service Subscription" section, and set "Block ANC Serv" to No and save the settings.

    You might want to look at the page on How to set up a Linksys PAP2 or Sipura SPA-2000 for use with FreePBX and to the extent that your settings correspond to those on a Linksys adapter, try to match them up as closely as possible - this will save you a lot of grief when using any FreePBX-based distribution.
     
  5. grant84

    Joined:
    Jan 13, 2009
    Messages:
    5
    Likes Received:
    0
    Thanks a lot for that. Thats all it was Block ANC ( Anonymous caller ). Why can't they just call it Block Anonymous Call instead of ANC :unsure:
     

Share This Page