Allow users to dial directly into a conference roo

Discussion in 'General' started by hinzinho, Sep 25, 2009.

  1. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    I have set up two Asterisk servers to allow direct dialing to user extensions. How can configure the PBX to allow the remote Asterisk box to dial directly into the conference room?

    For example:

    PBX-A : In CA with extension 5XXX
    PBX-B : In NY with extension 6XXX

    I have a conference room set up in PBX-A with the number 5800. I would like PBX-B to dial 5800 and get place into the conference automatically. Currently when they call the #, they are getting the message "All circuits are busy now". I can transfer them into the room manually.

    Thanks!
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    I can think of two things:
    1. You haven't set the correct outbound settings (dialing pattern to the conference room has not been defined)
    2. You are not using the correct context on your trunks

    Check this post:
    http://www.elastix.org/index.php?option ... 3&id=32110
     
  3. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    Calls between the two PBXs work fine with extensions. PBX-A can call PBX-B users and vice versa. However only local users from the PBX can call the conference room by dialing the # 5800. What I am looking for is how to allow the remote PBX to call 5800 and get place into the conf.

    I hope I am explaining this clearly,
     
  4. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    1. Paste the configuration that you have done on both trunks, as well.
    2. Paste the outbound routes that you have defined to reach the remote PBX.
     
  5. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    PBX-A
    IAX Trunk Settings
    Dial Rules: 12XX
    Trunk Name: ATLWAL
    Peer Details:
    host=192.168.120.252
    qualify=yes
    type=friend

    Outbound Route
    Route Name: ATLWAL
    Dial Patterns: 12XX
    Trunk Sequence: IAX2/ATLWAL

    Conferences
    Number:5199

    PBX-B
    IAX Trunk Settings
    Dial Rules: 5XXX
    Trunk Name: ATLWAL
    Peer Details:
    host=192.168.50.220
    qualify=yes
    type=friend

    Outbound Route
    Route Name: ATLWAL
    Dial Patterns: 5XXX
    Trunk Sequence: IAX2/ATLWAL


    When PBX-B dial extension 5199, it gets the message "All circuits are busy now".
     
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    I will recommend you to use the context flag. Follow the guide that I have left you, it will solve your problems
     
  7. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    Thanks jgutierrez! That was it! All I have to do was add "context=from-internal" into the Peer details.
     

Share This Page