Agente desconectado..?!

Discussion in 'Elastix 2.x' started by Mpignataro, Jan 24, 2011.

  1. Mpignataro

    Joined:
    Oct 27, 2010
    Messages:
    1
    Likes Received:
    0
    Estimada comunidad,

    Estoy frente a mi primera instalación del modulo de call center y tengo un problema
    que me está superando. Se trata de una desconexión de todos los agentes al mismo tiempo, en la pantalla
    de la consola me sale un popup que me dice "agente desconectado: error al conectarse con el administrador asterisk".

    Estoy utilizando Elastix-1.6-12 con FreePBX 2.6 y la versión 1.5-3.7 del módulo de call center.

    En los logs del dialer me sale esto en el momento de la desconexión:

    2011-01-24 13:46:28 : (DialerProcess) ERR: problema al esperar respuesta de Asterisk (en bucle de espera).
    2011-01-24 13:46:28 : (DialerProcess) INFO: Desconectando de sesión previa de Asterisk...
    2011-01-24 13:46:28 : (DialerProcess) INFO: Iniciando sesión de control de Asterisk...
    2011-01-24 13:46:28 : (DialerProcess) Warning: /opt/elastix/dialer/phpagi-asmanager-elastix.php line 276 - fsockopen(): unable to connect to 127.0.0.1:5038 (Connection refused)
    2011-01-24 13:46:28 : (DialerProcess) Unable to connect to manager 127.0.0.1:5038 (111): Connection refused
    2011-01-24 13:46:28 :
    (13:11:53) Fabi - : (DialerProcess) FATAL: no se puede conectar a Asterisk Manager

    2011-01-24 13:46:28 : (DialerProcess) INFO: Iniciando sesión de control de Asterisk...
    2011-01-24 13:46:28 : (DialerProcess) Warning: /opt/elastix/dialer/phpagi-asmanager-elastix.php line 276 - fsockopen(): unable to connect to 127.0.0.1:5038



    Alguien a pasado por la misma sitación? Qué combinación de versiones de Elastix, FreePBX y Call center module me recomiendan
    como más estable?

    Muchas gracias.
     
  2. Elendil

    Joined:
    Jul 14, 2011
    Messages:
    17
    Likes Received:
    0
    Estoy teniendo el mismo problema :S

    Los agentes se desloguean de manera esporádica con ese error. Seguiré investigando a ver que encunetro. Tu encontraste alguna solución?
     
  3. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
  4. Elendil

    Joined:
    Jul 14, 2011
    Messages:
    17
    Likes Received:
    0
    Hola jgutierrez


    Gracias por al respuesta, aunque use esos tutoriales para poder configurar el call center, primero tenía problemas porque no tenía iniciado el Dialer, pero ahora todo funciona bien para las colas de entrada y de salida.


    Quizá se deba a que tengo Asterisk 1.8.4-4 en Elastix 1.6 con el Call Center 1.5.4-4. Además de que había leído que el Call Center 1.5.4 tiene problemas con Elastix 1.6 :S.

    No he logrado visualizar un error o si quiera que los agentes se desloguen en el Dialer log, es algo un tanto extraño, si consigo capturar el momento en el log del Dialer lo pondré.

    En el log de Asterisk si aparece que se desloguean los agentes, pero aparece como si fuera un deslogueo normal.
     

Share This Page