After yum update, FOP doesn't display DAHDI trunks

Discussion in 'General' started by mastermindpro, Jun 10, 2009.

  1. mastermindpro

    Joined:
    May 28, 2009
    Messages:
    11
    Likes Received:
    0
    Subject line pretty much says it all. I ran a yum update on an Elastix 1.5 box to fix some issues with faxing, and afterward, the FOP no longer displays any Trunks. Any idea what I should check?
     
  2. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
    I have the same problem.

    gamba47
     
  3. haywoodcox

    Joined:
    Jun 11, 2009
    Messages:
    79
    Likes Received:
    0
    I also have the same problem...anyone know how to solve?
     
  4. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
  5. ronaldlw

    Joined:
    May 7, 2009
    Messages:
    81
    Likes Received:
    0
    I have the same issue, the fix suggested in the link did not work for me.

    Ron
     
  6. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
    Thanks ronaldlw for test it.


    gamba47
     
  7. ronaldlw

    Joined:
    May 7, 2009
    Messages:
    81
    Likes Received:
    0
    any update on this?

    Thanks,
    Ron
     
  8. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
    I format my box.


    gamba47
     
  9. saleh

    Joined:
    Apr 18, 2007
    Messages:
    249
    Likes Received:
    0
    To fix it, please edit the file retrieve_op_conf_from_mysql.pl under the directory: /var/lib/asterisk/bin

    and change the file name zapata-auto.conf or zapata-channels.conf to dahdi-channels.conf

    After making this changes, go to the PBX Configuration and edit any think like edit an extension and submit then "Apply configuration changes" then go to the FOP to see the DAHDI trunks
     
  10. ronaldlw

    Joined:
    May 7, 2009
    Messages:
    81
    Likes Received:
    0
    thanks saleh, that worked great! Any idea what the deal was with this? I'm going to be MUCH more careful with yum updates from now on! I also had major problems with the module update in freepbx recently. Thankfully this is a pre-production server, or I wouldn't have run ether update without testing first!

    Thanks again,
    Ron
     
  11. gamba47

    Joined:
    May 28, 2009
    Messages:
    595
    Likes Received:
    0
    saleh!!! you are the man!!!

    Thanks for the solution. I update my new box again a have the same problem.

    Now it´s fixed.


    Regards. gamba47
     
  12. miclshui

    Joined:
    Sep 23, 2009
    Messages:
    5
    Likes Received:
    0
    Questions remain
     
  13. aplusmiami

    Joined:
    Oct 20, 2009
    Messages:
    2
    Likes Received:
    0
    I am running a stock install. I installed the wanpipe drivers dadhi and everything works except i can not see the analog trunks on my sangoma card in the FOP. I checked the file previously mentioned and it does have the dadhi_channels on line 21 etc.. What am I missing?
     
  14. syadnom

    Joined:
    Aug 4, 2009
    Messages:
    36
    Likes Received:
    0
    same here.
    my sangoma install process is

    wancfg_dahdi
    dahdi_genconf

    but FOP doesnt see them. I have messed with the FOP .pl file and replaced the zapata.conf with chan_dahdi.conf and also tried to just link chan_dahdi.conf to zapata.conf. no luck.

    any other ideas?
     
  15. syadnom

    Joined:
    Aug 4, 2009
    Messages:
    36
    Likes Received:
    0
    my solution is

    wancfg_dahdi
    dahdi_genconf
    go into freepbx, go into the trunk and hit submit, then apply the settings. should work.

    Thanks
     

Share This Page