After yum update, FOP doesn't display DAHDI trunks

mastermindpro

Joined
May 28, 2009
Messages
11
Likes
0
Points
0
#1
Subject line pretty much says it all. I ran a yum update on an Elastix 1.5 box to fix some issues with faxing, and afterward, the FOP no longer displays any Trunks. Any idea what I should check?
 

gamba47

Joined
May 28, 2009
Messages
595
Likes
0
Points
0
#2
I have the same problem.

gamba47
 

haywoodcox

Joined
Jun 11, 2009
Messages
79
Likes
0
Points
0
#3
I also have the same problem...anyone know how to solve?
 

gamba47

Joined
May 28, 2009
Messages
595
Likes
0
Points
0
#4

ronaldlw

Joined
May 7, 2009
Messages
81
Likes
0
Points
0
#5
I have the same issue, the fix suggested in the link did not work for me.

Ron
 

gamba47

Joined
May 28, 2009
Messages
595
Likes
0
Points
0
#6
Thanks ronaldlw for test it.


gamba47
 

ronaldlw

Joined
May 7, 2009
Messages
81
Likes
0
Points
0
#7
any update on this?

Thanks,
Ron
 

gamba47

Joined
May 28, 2009
Messages
595
Likes
0
Points
0
#8
I format my box.


gamba47
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#9
To fix it, please edit the file retrieve_op_conf_from_mysql.pl under the directory: /var/lib/asterisk/bin

and change the file name zapata-auto.conf or zapata-channels.conf to dahdi-channels.conf

After making this changes, go to the PBX Configuration and edit any think like edit an extension and submit then "Apply configuration changes" then go to the FOP to see the DAHDI trunks
 

ronaldlw

Joined
May 7, 2009
Messages
81
Likes
0
Points
0
#10
thanks saleh, that worked great! Any idea what the deal was with this? I'm going to be MUCH more careful with yum updates from now on! I also had major problems with the module update in freepbx recently. Thankfully this is a pre-production server, or I wouldn't have run ether update without testing first!

Thanks again,
Ron
 

gamba47

Joined
May 28, 2009
Messages
595
Likes
0
Points
0
#11
saleh!!! you are the man!!!

Thanks for the solution. I update my new box again a have the same problem.

Now it´s fixed.


Regards. gamba47
 

miclshui

Joined
Sep 23, 2009
Messages
5
Likes
0
Points
0
#12
Questions remain
 

aplusmiami

Joined
Oct 20, 2009
Messages
2
Likes
0
Points
0
#13
I am running a stock install. I installed the wanpipe drivers dadhi and everything works except i can not see the analog trunks on my sangoma card in the FOP. I checked the file previously mentioned and it does have the dadhi_channels on line 21 etc.. What am I missing?
 

syadnom

Joined
Aug 4, 2009
Messages
36
Likes
0
Points
6
#14
same here.
my sangoma install process is

wancfg_dahdi
dahdi_genconf

but FOP doesnt see them. I have messed with the FOP .pl file and replaced the zapata.conf with chan_dahdi.conf and also tried to just link chan_dahdi.conf to zapata.conf. no luck.

any other ideas?
 

syadnom

Joined
Aug 4, 2009
Messages
36
Likes
0
Points
6
#15
my solution is

wancfg_dahdi
dahdi_genconf
go into freepbx, go into the trunk and hit submit, then apply the settings. should work.

Thanks
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top