Adding Custom VOIP Provider

Discussion in 'General' started by jpb, Feb 11, 2011.

  1. jpb

    jpb

    Joined:
    Sep 16, 2008
    Messages:
    22
    Likes Received:
    0
    Hello there

    I have trouble adding my chosen VOIP Provider to Elastix
    On the [PBX]->[VoIP Provider] tab you have a choice of 4 or 5 providers but the in Another country or something. How can I add / Amend or change that so My own provider can be used?

    You can suggest any Alternative configuration meathod also.

    I think the Elastix team dint really think this one through!


    Thanx ;)
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    JUst to make it clear, this module was designed for voip provider that have already been tested or have requested to be included on the list.
    If your provider is not on the list, you may still configure it manually creating the trunk, and setting up the paramenters that it request.
    The voip provider module, was though to make a configuration easier and quicker, but the oldfashion mode is still there (create and configure trunks)
     
  3. hdking

    Joined:
    Oct 17, 2012
    Messages:
    8
    Likes Received:
    0
    Hi

    I just installed today Elastix 2.3.0 on my virtualbox on a mac.
    I configured my VOIP provider which is peoplefone in Elastix under PBX/VoIP Providers:

    Outgoing Settings
    host=app1.peoplefone.ch
    username=my user ID from peoplefone
    secret=my password from peoplefone
    type=peer
    qualify=no
    insecure=very
    dtmfmode=rfc2833
    context=Unvailable
    trustrpid=no
    sendrpid=no
    canreinvite=no

    Incomming Settings
    empty

    In my peoplefone account under device it is green and states "FPBX-2.8.1(1.8.11.0)"

    To call I use X-Lite. The connection in the settings under account is enabled and green.
    When I dial a number the voice is saying following: "your call can not be completed as dialed, please check the number an dial again"
    The phone number I dial is +41 43 343 10 73 (just to test).

    Attached you can find the log file from X-Lite client
    Download
     
  4. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    If you have that issue from elastix, that is because you have not configured any outbound route with such dial pattern.

    Take a look at elastix without tears manual on the book/manual section on this forum to configure your outbound routes.
     
  5. hdking

    Joined:
    Oct 17, 2012
    Messages:
    8
    Likes Received:
    0
    Hi

    I assumed it and I also checked documentation i.e. "5.5 What is dial pattern?" in Elastix Easy but I am not able to hit the right pattern :)

    First I would like to test numbers from switzerland

    Countrycode: 0041
    Nubmering Zone for Zurich: 43 or 44
    Number of to be called: 343 10 73

    My pattern proposal would be:
    prepend:XXXX
    prefix: XX
    matchpattern: XXX XX XX
    callerID: "empty"

    But I get "dial pattern invalid" if I do it like that.

    I would appreciate if you can help me with this

    here the printscreen
    https://dl.dropbox.com/u/21292273/forum ... 0route.png
     
  6. keler

    Joined:
    May 25, 2012
    Messages:
    35
    Likes Received:
    0
    Please can you help me to finalize my project. It's about 10 IP Phone 8941 that I would like to convert in SIP. but the had stardted to download the files and when Stops when arrived at "gb-sccp-sip.jar"

    Please Help.
     

Share This Page