About call record.

Discussion in 'General' started by cyanchan, May 20, 2010.

  1. cyanchan

    Joined:
    May 4, 2010
    Messages:
    3
    Likes Received:
    0
    Pls help about call record.
    I find customer volume are so small in the record.
    How do I adjust the volume up?
    Thanks a lot.

    :)
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    What I would do is the following:
    1. Open /etc/asterisk/extensions_addtional.conf
    2. Look for the macro-record-enable context and copy it
    Code:
    [macro-record-enable]
    include => macro-record-enable-custom
    exten => s,1,GotoIf($["${BLINDTRANSFER}" = ""]?check)
    exten => s,n,ResetCDR(w)
    exten => s,n,StopMonitor()
    exten => s,n(check),AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,n,MacroExit()
    exten => s,1+998(record),MixMonitor(${MIXMON_DIR}${CALLFILENAME}.${MIXMON_FORMAT},,${MIXMON_POST})
    
    3. Edit /etc/asterisk/extensions_override_freepbx.conf, and paste the following:
    Code:
    [macro-record-enable]
    include => macro-record-enable-custom
    exten => s,1,GotoIf($["${BLINDTRANSFER}" = ""]?check)
    exten => s,n,ResetCDR(w)
    exten => s,n,StopMonitor()
    exten => s,n(check),AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,n,MacroExit()
    exten => s,1+998(record),MixMonitor(${MIXMON_DIR}${CALLFILENAME}.${MIXMON_FORMAT},W(2),${MIXMON_POST})
    
    Where the W value ranges from -4 to 4
    4. Execute from the shell:
    asterisk -rx "module reload"
     
  3. cyanchan

    Joined:
    May 4, 2010
    Messages:
    3
    Likes Received:
    0
    Thank you very much ,

    Let me test.
    ;)
     

Share This Page