8139too auto down

Discussion in 'General' started by leiw3248, Oct 24, 2009.

  1. leiw3248

    Joined:
    Apr 21, 2008
    Messages:
    476
    Likes Received:
    0
    Hello

    This few days the eth0 RL8139 always auto shutdown, the following is message log information:

    Oct 23 12:28:46 elastix avahi-daemon[2621]: Invalid query packet.
    Oct 23 12:28:47 elastix last message repeated 2 times
    Oct 23 13:26:52 elastix ntpd[2090]: synchronized to 202.131.74.125, stratum 2
    Oct 23 13:38:43 elastix ntpd[2090]: synchronized to 218.189.212.239, stratum 2
    Oct 23 14:01:22 elastix ntpd[2090]: synchronized to 202.131.74.125, stratum 2
    Oct 23 14:17:28 elastix ntpd[2090]: synchronized to 218.189.212.239, stratum 2
    Oct 23 15:01:25 elastix avahi-daemon[2621]: Invalid query packet.
    Oct 23 15:10:35 elastix last message repeated 3 times
    Oct 23 15:10:36 elastix last message repeated 2 times
    Oct 23 16:16:40 elastix auditd[1649]: Audit daemon rotating log files
    Oct 23 16:52:09 elastix ntpd[2090]: synchronized to 202.131.74.125, stratum 2
    Oct 23 17:01:49 elastix ntpd[2090]: synchronized to 218.189.212.239, stratum 2
    Oct 23 18:17:39 elastix kernel: eth0: link down
    Oct 23 18:20:13 elastix ntpd[2090]: synchronized to 202.131.74.125, stratum 2
    Oct 23 18:22:20 elastix kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    Oct 23 18:33:40 elastix ntpd[2090]: synchronized to 218.189.212.239, stratum 2
    Oct 23 19:26:49 elastix kernel: eth0: link down
    Oct 23 19:36:34 elastix ntpd[2090]: synchronized to 202.131.74.125, stratum 2
    Oct 23 20:17:14 elastix ntpd[2090]: synchronized to LOCAL(0), stratum 10

    And modprobe information:

    [root@elastix ~]# cat /etc/modprobe.conf
    alias eth0 8139too

    Thank !
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Indicates you have a problem with your physical layer of the network (no ethernet connection), check your wiring and switches, the link lights on both ends will help you here, if all else fails replace your network card, (I doubt whether that's the problem though, if it just started happening).
     
  3. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    Hi leiw3248,

    There are a few things you can do and it is a known issue with some kernels and I believe in particular the 8139C card (haven't seen a 8139D affected yet). It is most common as everyone has an 8139C card(s) sitting in a draw, or the motherboard has a 8139c built into it.

    Now one option is to add pci=noacpi in the boot parameters (basically look up BOOT PCI NOACPI 8139)

    Another is to make sure that in the BIOS, if possible all Powersaving options are turned off (Let Linux handle it). The main issue I believe is the Wake On LAN (WOL) is not functioning correctly and gets stuck off or bounces around.

    And the final one is to replace the card as Dicko said (especially due to the negligible cost).

    Now having said that, I am assuming that it has only just started happening, so it is a little unusual...possibilities that may have occured

    1) Bios in system reset to defaults turning power features back on
    2) Done a YUM update recently which has updated the kernel (and changed the behaviour)

    So if all above doesn't sound normal, then going back to what Dicko said, it has to be at the Physical layer

    1) Cable is crook
    2) Switch is crook
    3) Switch is having trouble with auto negotiation. If possible set switch to a particular setting instead of autonegotiate....if switch is a dumb switch, then set network card using ETHTOOL at command line. (search for ETHTOOL SPEED DUPLEX)

    Hope this helps

    Bob
     
  4. leiw3248

    Joined:
    Apr 21, 2008
    Messages:
    476
    Likes Received:
    0
    Thank Bob, I will try it later !

    Thank !
     

Share This Page