2 trunk on same provider : one not working

Discussion in 'General' started by saidmsl, Apr 2, 2010.

  1. saidmsl

    Joined:
    Nov 20, 2008
    Messages:
    65
    Likes Received:
    0
    Hi,

    i someone can help :

    i had an elastix server (1.6) with 2 accounts on same voip provider. worked fine

    i prepare a new server and recopy all settings.
    now if i enable both accounts, only one works

    error i get :

    <------------->
    [Apr 2 07:02:12] VERBOSE[14532] logger.c: --- (11 headers 0 lines) ---
    [Apr 2 07:02:12] VERBOSE[14532] logger.c:
    <--- SIP read from x.x.x.x:5060 --->
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP 192.168.1.3:5060;branch=z9hG4bK3cf5e0c1;received=196.27.78.77;rport=5060
    From: "0123456789" <sip:0123456789@x.x.x.x>;tag=as5596ee90
    To: <sip:0123456798@x.x.x.x>;tag=as4305bdb7
    Call-ID: 5c2b14695df0052a59204cfb394383aa@x.x.x.x
    CSeq: 102 INVITE
    User-Agent: Asterisk PBX 1.6.0.6
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Supported: replaces, timer
    WWW-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="50690b60"
    Content-Length: 0


    <------------->
    [Apr 2 07:02:12] VERBOSE[14532] logger.c: --- (11 headers 0 lines) ---
    [Apr 2 07:02:12] VERBOSE[14532] logger.c:
    <--- SIP read from x.x.x.x:5060 --->
    SIP/2.0 403 Forbidden
    Via: SIP/2.0/UDP 192.168.1.3:5060;branch=z9hG4bK7afe4282;received=196.27.78.77;rport=5060
    From: "0123456789" <sip:0123456789@x.x.x.x>;tag=as5596ee90
    To: <sip:0123456798@x.x.x.x>;tag=as4305bdb7
    Call-ID: 5c2b14695df0052a59204cfb394383aa@x.x.x.x
    CSeq: 103 INVITE
    User-Agent: Asterisk PBX 1.6.0.6
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Supported: replaces, timer
    Content-Length: 0


    i'm behind an adsl modem and use g729 codec. the call is using the 1st account
    192.168.1.3 is my local ip address
    x.x.x.x is the ip address of the provider
    0123456789 is my DID
    0123456798 is the number i call

    passwords are ok because if i'm using a softphone and i configure the account there it works

    if i disable one or other, the trunks works fine


    PS :

    latest elastix :
    asterisk 1.4.30, freepbx 2.7
    sip show registry :
    x.x.x.x:5060 user2 105 Registered Fri, 02 Apr 2010 07:17:29
    x.x.x.x:5060 user1 105 Registered Fri, 02 Apr 2010 07:17:30


    sip show peers :

    user2/user2 x.x.x.x N 5060 OK (1479 ms)
    user1/user1 x.x.x.x N 5060 OK (474 ms)

    trunk :
    username=user1
    type=peer
    secret=password
    host=x.x.x.x
    disallow=all
    allow=g729
    qualify=yes
    nat=yes
    insecure=very
    fromdomain=x.x.x.x
    context=from-trunk

    register string is set to : user1:password@x.x.x.x/0123456789
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    sorry repeated answer...
     
  3. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    sometimes certain providers use different ports to simultaneous connections so try to use 5060 and 5061 as ports in trunks

    not the best solution but with some providers work
     
  4. bluenet

    Joined:
    May 13, 2010
    Messages:
    12
    Likes Received:
    0
    Telephony Interface Hardware
    Product Roundup
    Product Features
    PC interfaces: PCI
     
  5. rgranados

    Joined:
    May 22, 2010
    Messages:
    61
    Likes Received:
    0
    Re: Re:2 trunk on same provider : one not working

    Had you checked if they both work with g711?

    If so maybe this could be a problem with g729 license.

    Hope be helpful.
     

Share This Page