1.6 VS. 2.0

Discussion in 'General' started by yukon9, May 7, 2010.

  1. yukon9

    Joined:
    Apr 5, 2010
    Messages:
    29
    Likes Received:
    0
    I useSIP trunk from a local VOIP provider. The trunk registered well on both elastix server.

    Elastix 2.0 performs very good, but with a small bug, can't add event on agenda.

    However, when I use elastix 1.6, SIP trunk and extension register well. call out well, but always problem with incoming call, always " the number you dial is not in service,........" Anything wrong?
     
  2. coryjsanders

    Joined:
    Mar 25, 2010
    Messages:
    181
    Likes Received:
    0
    Check your sip_nat.conf file and make sure you have this:
    nat=yes
    externip=<your public ip>
    localnet=192.168.1.0/255.255.255.0 <this is mine. You may be a 10.10.x.x/24 or something else.>
     
  3. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    ss-no service is inbound route issue

    Try anyDID/anyCID for that inbound trunk to see if it works
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi.

    Remember that Elastix V2.0 isn't a stable version, is only a RC version!!!
    So, we can't compare the performances with the 1.6, but only the packages. :huh:

    Regards
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Hey Franck:

    Sorry I missed your "meeting"
     
  6. yukon9

    Joined:
    Apr 5, 2010
    Messages:
    29
    Likes Received:
    0

    I did it in both ELASTIX 1.6 AND 2.0
     
  7. yukon9

    Joined:
    Apr 5, 2010
    Messages:
    29
    Likes Received:
    0
    It's interesting I didn't encounter big problem with elastix 2.0 till now, but lots of problem with 1.6.
     
  8. yukon9

    Joined:
    Apr 5, 2010
    Messages:
    29
    Likes Received:
    0
    tried, still doesn't work. perhaps it's my VOIP provider's problem, but it seems no problem when I install it on elastix 2.0.
     
  9. yukon9

    Joined:
    Apr 5, 2010
    Messages:
    29
    Likes Received:
    0
    I also try to use elastix 2.0's extension as elastix 1.6's SIP strunk, encounter same.
     
  10. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    If you have allow anonymous sip set to yes in general settings does it work?

    If it does update freepbx to 2.6 and turn off allow anonymous sip and should work if trunk is configured correct
     
  11. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    It's false, you can't say this. :huh:
    Each installs are different. It's possible that you haven't any problem with your config, but it's not really the case for the others.

    The 1.6 is more stable than the 2.0.
    Since how many time a RC is more stable than the stable version? :blink:

    Every Alpha, Beta, and RC versions are make to be tested, So.

    Myself, I use the 1.6.21 and no problem. Every extensions and trunks works fine. ;)

    With the 2.0 Beta, without Freepbx 2.7, this version not works.
    The RC is better than the Beta, ouf course, but thas all.

    You can't install this version in production. But, you can install it for any test and reports bugs that the Dev Team try to fix every bugs reported.
     
  12. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Irrelevant
    ;)
     
  13. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    I have found that some SIP providers require that your pbx be in the DMZ or on the outside network. Some don't work behind a nat. They will register one way but not both. Check to see that both your pbx's are on the outside or in a DMZ. Just a thought.
     
  14. yukon9

    Joined:
    Apr 5, 2010
    Messages:
    29
    Likes Received:
    0
    Contact my VOIP provider and follow their intruction on sip trunk setting. The problem is resolved finally.


    Very appreciated for everyone herein. :)
     

Share This Page