1.6 stable with soft RAID network card issue

Discussion in 'General' started by chris111, Nov 18, 2009.

  1. chris111

    Joined:
    Nov 15, 2007
    Messages:
    30
    Likes Received:
    0
    I have an issue with Elastix 1.6 and soft RAID. I partition 2 identical drives, installation goes smooth, no issues at all. I log in to console, my server doesn't pull the IP from my DHCP server (router). Unable to edit my network, "setup" does not work neither does system-config-network. Cannot ping or install due to DNS issues. If I install without partitioning, I have no problems. 1.5.3 works fine with same partitions, I double and triple checked my config. Is there a bug in 1.6 (I don't see why my RAID would cause issues). Help please, pulling out my hair over this one.

    Thanks.
     
  2. mcamerar

    Joined:
    Nov 25, 2009
    Messages:
    25
    Likes Received:
    0
    I have exactly the same problem...
    I don't know why without raid work the network card and with raid1 I cannot see it.
    Please Help
     
  3. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    What model of motherboard are you using or what is the machine model (in the case of brand name)....

    Also can you perform a lspci at the linux prompt and provide the results...

    Regards

    Bob
     
  4. mcamerar

    Joined:
    Nov 25, 2009
    Messages:
    25
    Likes Received:
    0
    Incredible !
    I just solved myself and was really easy for a newbie like me!!!
    I just follow the instructions attached to install the driver of my network card which is Realtek RTL8111.
    For newbies like me I put instructions here....

    <Quick install with proper kernel settings>
    Check whether the built-in driver, r8169.ko (or r8169.o for kernel 2.4.x), is installed.
    # lsmod | grep r8169

    If it is installed, please remove it.
    # rmmod r8169
    note: If the built-in driver cannot removed by rmmod, please edit /etc/modprobe.conf and comment 'alias eth0 r8169'. Then, remmove it again or reboot your computer.

    Unpack the tarball :
    # tar vjxf r8168-8.aaa.bb.tar.bz2

    Change to the directory:
    # cd r8168-8.aaa.bb

    If you are running the target kernel, then you should be able to do :

    # make clean modules (as root or with sudo)
    # make install
    # depmod -a
    # modprobe r8168

    You can check whether the driver is loaded by using following commands.

    # lsmod | grep r8168
    # ifconfig -a

    If there is a device name, ethX, shown on the monitor, the linux driver is loaded. Then, you can use the following command to activate the ethX.

    # ifconfig ethX up

    ,where X=0,1,2,...

    <Set the network related information>
    1. Set manually
    a. Set the IP address of your machine.

    # ifconfig ethX "the IP address of your machine" (any ip that you know to be free!)

    b. Set the IP address of DNS.

    Insert the following configuration in /etc/resolv.conf.

    nameserver "the IP address of DNS"

    c. Set the IP address of gateway.

    # route add default gw "the IP address of gateway"

    2. Set by doing configurations in /etc/sysconfig/network-scripts
    /ifcfg-ethX for Redhat and Fedora, or
    /etc/sysconfig/network
    /ifcfg-ethX for SuSE.
    There are two examples to set network configurations.

    a. Fix IP address:
    DEVICE=eth0
    BOOTPROTO=static
    ONBOOT=yes
    TYPE=ethernet
    NETMASK=255.255.255.0
    IPADDR=192.168.1.1
    GATEWAY=192.168.1.254
    BROADCAST=192.168.1.255

    b. DHCP:
    DEVICE=eth0
    BOOTPROTO=dhcp
    ONBOOT=yes


    Hope have been helpfull!!
     

Share This Page