1.6 and Dahdi, using PRI's in the US

Discussion in 'General' started by rollinsolo, Dec 16, 2009.

  1. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    I recently performed an upgrade for a customer from 1.3 to 1.6 mainly because I wanted to learn 1.6, and dahdi using a PRI, I started from scratch, I got Elastix to recognize the Rhino Card, using dahdi_genconf, restarted and configured dahdi_channels.conf to reflect the correct # of channels, restarted and in the channels were correct on the web interface.

    The problem is that the D-Channel kept going down, I did some trouble shooting with the carrier to make sure they got connection signals from my box and they did, but then he would see the D-Channel go in and out, this whole process took a few hours and I could not leave them in a non working state so I loaded 1.3 and did a restore reconfigured the zapata channels and everything was back up in 20 mins. Has anyone had any similar issues using Dahdi, is it just not there yet for US signaling. I even made sure to trouble shoot with Rhino techs to make sure I had the latest drivers for Dahdi. Is there any chance we can incorporate Zapata back into Elastix. Thanks All.
     
  2. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    I recently read about a patch to fix some signaling issues, was this something that could have addressed my problem as stated before. I will have to find the article and will post it here.
     
  3. hinzinho

    Joined:
    Sep 18, 2009
    Messages:
    461
    Likes Received:
    0
    I am using Dahdi w/ PRI and had some issue in the beginning until I upgraded the dahdi driver. The symptom was that circuit would go down and then get the "all circuits are busy now". Hope that help.
     
  4. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    How did you upgrade the dahdi driver can you give me some more details on how you did this, what was missing before and what got added after for everything to work right?

    Also what kind of card were you using.
     
  5. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    with bruno macias i ve seen this type of behaviour in sangoma cards also and redfones...so its a dahdi compillation issue ...1.6 has many issues in dahdi and kernel old versions...so what i do to avoid this issues ....
    download and replace old 164 kernel with latest one 11.1 from centos
    download and replace sangoma wanpipe old version with latest 3.5.10, download and replace old dahdi 2.2.0 version with latest 2.2.1 and upgrade all elastix asterisk soft (1.4.29.1 addons 1.4.10.2 and libpro to 1.4.10.2 with many others) and then voila as expected all problems solved...

    but in other many cases d channel issues could be caused by poor hardware and irq issues...
    dahdi_tool is a good too to test this for irq misses...

    using sangoma digium or redfone is a warranty of less problems

    best regards
     
  6. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    Ok this might sound stupid, how do you replace the kernel in Elastix with Centos Latest, I gave your post a once over you make it sound easy, but could you give me some more specific type commands to experiment with until I get a feel to what is happening to the OS as I make changes. Thanks.
     
  7. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    first of all go to etc yum.repos.d then base.repo and remove exclude=kernel* lines, save and then yum upgrade -y old kernels will be left for backup and new one gets installed then you have to compile by hand dahdi and sangoma driver or the one that you need...watch out to do first this steps in a vm machine or test system not a production one and always keep backup pre and post test.

    see ya
     
  8. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    Ok thanks, I am curious if I just upgraded the dahdi drivers alone as mentioned above would fix the issue, I would like to try both for sure. Thanks Again.
     
  9. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    i hate rpm made by others so i will allways prefer to compile my own drivers from scratch but latest dahdi included in elastix rpm modules work fine as of today with the old .164 kernel also sangoma drivers and redfone 2.0 works ok...so its just a matter of liking one or the the other method

    see ya
     
  10. rollinsolo

    Joined:
    Feb 11, 2009
    Messages:
    279
    Likes Received:
    0
    Can you post a script to update to the latest Dahdi Drivers, and LibPRI with Elastix 1.6? I will give you Karma until I can no longer Give Karma.
     

Share This Page