1.5.2 WANPIPE error

Discussion in 'General' started by AZNET, Jun 18, 2009.

  1. AZNET

    Joined:
    Jun 18, 2009
    Messages:
    5
    Likes Received:
    0
    We did a upgrade from 1.3.2 and we had the issue that has already been reported with 1.5.2 with the WANPIPE and Sangoma cards.

    We tried a clean install and updates, but still have the issue. From what I have read on other post it's the WANPIPE RPM that is in question.

    wanpipe: no version for "dahdi_alarm_notify"
    No Sangoma card found

    Is there any updates on this issue?

    Thanks
     
  2. AZNET

    Joined:
    Jun 18, 2009
    Messages:
    5
    Likes Received:
    0
    After jacking around with this for most of the night and this morning, we installed another VOIP platform just to get the system up and running for now.

    We like Elastix very much, and will reinstall 1.3 when we have more time to mess with it, and stay with the 1.3 until the WANPIPE RPM is fixed.
     
  3. mihpel

    Joined:
    May 8, 2007
    Messages:
    87
    Likes Received:
    0
    less than 24 hours ago i've had successfully used the latest wanpipe rpm with an A500D with 6 bri channels and an A400D with 24 fxs.

    can you be more spesific about the prosedure you have followed ?

    Did you try reinstalling wanpipe after the update?

    I am expecting another set of a400 & a500 by morning so i will be able to test with a clean system.

    meanwhile you could follow the prosedure described in this post :

    http://www.elastix.org/index.php?option=com_fireboard&Itemid=55&func=view&catid=1&id=23541&limit=10&limitstart=10#26396

    to get it to work.

    Strange though........
     
  4. mihpel

    Joined:
    May 8, 2007
    Messages:
    87
    Likes Received:
    0
    in case you decide to test, could you post the output of the following commands ?

    Code:
    rmp -qa | grep wanpipe
    Code:
    lsmod | grep wan
    Code:
    head -30 /etc/wanpipe/wancfg_zaptel/wancfg_zaptel.pl | grep \ 2
    Code:
    rpm -qa | grep dahdi
     
  5. AZNET

    Joined:
    Jun 18, 2009
    Messages:
    5
    Likes Received:
    0
    Thanks mihpel,

    I'll give it a try this weekend.

    We were currently running on version 1.3.2 and we did the update through yum. I searched the forums and tried reinstalling the wanpipe, but it did not help.

    We did a clean install of 1.5.2 and had the same issue, updated the system, still no good, we tried the beta updates, still no good.

    I'm not sure how I missed the post you referred me to, but I will give it a try this weekend.

    I think I might have to have a few Jack n Cokes tonight to help heal to wounds.

    Thanks again.
     
  6. mihpel

    Joined:
    May 8, 2007
    Messages:
    87
    Likes Received:
    0
    What i have concluded, through pain, regarding the update prosedure from 1.3.2 to 1.5.2 is that that i have to run yum update repeatedly until no updates are left and right before i boot the machine....

    change the boot order in /etc/grub.conf, set non-xen kernel as default, and change /etc/sysconfig/kernel "DEFAULTKERNEL=kernel-xen" to "DEFAULTKERNEL=kernel"

    Wanpipe goes crazy with xen!!!

    After the reboot you have to reinstall wanpipe-util and kernel-module-wanpipe to update some wrong version retained scripts (leftovers of the first wanpipe rpm that touched the system).

    Also make sure you correctly update freePBX.

    After testing today i found that there are some remaining problems regarding the wanpipe rpms that are being looked into, but if you have no time to wait go for the source install following the steps from the post i previously gave you and you should be ok.
     

Share This Page