1.4 Elastix outgoing call fine, income faulty

Discussion in 'General' started by theme, Nov 20, 2008.

  1. theme

    Joined:
    Nov 3, 2008
    Messages:
    6
    Likes Received:
    0
    Hi everybody,

    I am install 1.4 Elastix, also can use phone call out, but I can't call in .
    "0402345671" <0402345671> s ANSWERED 00:02
    SIP/092118... 0280088000 "0280088880" <0280088000> s ANSWERED 00:02
    SIP/092118... 0280088000 "0280088880" <0280088000> s ANSWERED 00:02
    SIP/092118... 0280088000 "0280088000" <0280088000> s ANSWERED 00:02
    SIP/092118... 0280088000 "0280088000" <0280088000> s ANSWERED 00:02
    SIP/092118... 0280088000 "0280088000" <0280088000> s ANSWERED 00:03
    SIP/092118... 0390055338 "TA612V Line 1" <039456738> s ANSWERED 00:09
    SIP/10-b75... 61390059255 "Cocc4" <61390053355> 90390052348 NO ANSWER 00:04
    SIP/092118... 0390055338 "TA612V Line 1" <039345678> s ANSWERED 00:07

    The log show is Answered. But the phone is not ring. "S" means start. It can't find the extension phone,isn' it?

    and I checked the cli the trunks is registered.That's my user details:
    dtmfmode=rfc2833
    fromuser=09*****
    host=sip00.devicoe.com
    insecure=very
    nat=yes
    pedantic=no
    qualify=yes
    secret=******
    type=friend
    username=09*******

    I don't know what's problem on this server.
     
  2. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    Where's your context statement? Without one, incoming calls have no place to go. Try adding:

    context=from-trunk

    Also make sure you have set up an inbound route. And if after doing those things, you still can't get incoming calls to come in properly, see this page:

    http://www.freepbx.org/support/document ... nd-it-and-
     
  3. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Why you have put type=friend into the trunk?

    Normally, you must put type=peer, also you must put the context into this section : context=from-trunk
     
  4. theme

    Joined:
    Nov 3, 2008
    Messages:
    6
    Likes Received:
    0
    Hi danardf ,
    I change setting. It's same as before. I think some problem with extension setting.All the incoming call is can't transfer to extension. That's Log:



    -- Executing [09211894@from-sip-external:1] NoOp("SIP/09211833-b7700468", "Received incoming SIP connection from unknown peer to 09211894") in new stack


    -- Executing [09211894@from-sip-external:2] Set("SIP/09211833-b7700468", "DID=09211894") in new stack


    -- Executing [09211894@from-sip-external:3] Goto("SIP/09211833-b7700468", "s|1") in new stack

    Nov 20 19:01:27 VERBOSE [14728] logger.c:

    -- Goto (from-sip-external,s,1)
     
  5. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    General settings ,make sure you have allow anonymous sip allowed
     
  6. theme

    Joined:
    Nov 3, 2008
    Messages:
    6
    Likes Received:
    0
    yes..That's base setting.
     
  7. itjumper

    Joined:
    Jul 22, 2008
    Messages:
    81
    Likes Received:
    0
    Looks like improper registration. Should not use "allow anonymous sip" as this is not safe.

    May have problem resolving "host=sip00.devicoe.com". Any side is on dynamic IP? Try using registration string or IP.
     
  8. theme

    Joined:
    Nov 3, 2008
    Messages:
    6
    Likes Received:
    0
    Thanks a lots.
    I fix that problem. Problem is at context.
     
  9. kdiamond

    Joined:
    Dec 14, 2008
    Messages:
    5
    Likes Received:
    0
    I have the same problem. Can you please tell me more about in?
    Currently my context is my number: 059######

    Thank you

    Br,
    kd
     

Share This Page