1.3-2 stable and sangoma T1 cards

Discussion in 'General' started by voipdog, Oct 31, 2008.

  1. voipdog

    Joined:
    May 2, 2008
    Messages:
    30
    Likes Received:
    0
    All,

    Anybody get the sangoma T1 cards and Elastix Stable from Sept. 28th to work together?

    Carrier = Nuvox

    Can receive calls, but cannot place a call.

    Have the sangoma support looking at the system via ssh.

    just wondering if anybody else has this problem.

    Thanks

    voipdog
     
  2. Jason

    Joined:
    Nov 16, 2008
    Messages:
    2
    Likes Received:
    0
    We have two A102DE cards in our phone server, and I haven't been able to get outbound calls working either. Currently we're only testing the outbound,

    Initially the set up that the hardware detection didn't set it up correctly. I had to use the setup-sangoma program.

    Even then, I was getting a lot of rx excessive errors in the message logs.

    So then they had me change the zaptel.conf file to say dchan=24 instead of hardhdlc=24, which got rid of the errors, but I still couldn't make outbound calls.

    The error Asterisk shot up was "Trunk failed through because of CONGESTION"

    That's pretty much where I'm stuck at now.....

    Our Carrier is McLeod.
     
  3. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    VoIPDog,

    Can't comment on T1, but recently built Elastix 1.3-2 with Sangoma 101D as a test system on E1 line. Had no issues with build, using libraries supplied as part of Elastix 1.3-2 (e.g. no files downloaded off sangoma).

    Main steps I took were

    Installed Elastix 1.3-2
    run setup-sangoma
    performed hardware detection using Elastix hardware detection (clicking on Sangoma Card Installed).
    changed the country settings to Australia in Zaptel.conf (naturally that is only for where I am)

    In the Zapata.conf, modified or added the lines
    pridialplan=unknown
    prilocaldialplan=unknown
    overlapdial=yes


    The settings above are necessary for outbound calls...and from anecdotal evidence, these are important for outbound calls to work.

    When working with zaptel.conf noticed the hardhdlc setting, and coming from the digium card camp, I had not seen this before, so change to dchan. This however caused the E1 to bounce (dchannel bounced up and down). Put back to hardhdlc=16 (for E1) setting and no errors.

    Tested system with both inbound and outbound calls. Working successfully.

    Don't know if anything in here helps, but can confirm that from an E1 point of view, the Elastix 1.3-2 appears to have no major issues with the Sangoma Card.

    Regards

    Bob
     
  4. voipdog

    Joined:
    May 2, 2008
    Messages:
    30
    Likes Received:
    0
    Jason

    Look at the cli commands for asterisk. There is one of the top of my head I cannot rememeber that you use to debug T1 links Look for the pri commands in the cli help menu.

    Can you get calls in?

    Try to get a McLeod network engineer on the phone to watch what the pri is doing. Lots of time they can tell you right away whats going on.

    If you can get calls in, but cannot call out it is a problem with what dial patterns you are sending to Mcleod. The network engineer should be able to tell if you ar3e sending the write dial strings eg you are sending NPA-NXX-XXXX when you should be sending +1NA_-NXX-XXXX

    Hope this helps!!

    JJS
     
  5. Jason

    Joined:
    Nov 16, 2008
    Messages:
    2
    Likes Received:
    0
    Well, I see on Sangoma's site that I should run a Trace first, with wanpipemon -i w1g1 -c trd.

    But it gives me nothing. On their site it says if there is nothing there, it's because the TDMV_DCHAN is set to 24 and to change it to 0. Well, did that and it still didn't change anything.

    From somewhere else I read that if the 'pri show span 1' is ran and shows "Provisioned, Down, Active" then there is still a problem with the link. That's where I'm at now.

    I think it really is something with the Sangoma card setup. I do know that the wanpipemon program crashes a lot and half of the commands don't work, like the self test, etc.
     
  6. my898

    Joined:
    Jan 6, 2009
    Messages:
    7
    Likes Received:
    0
    Hi Bob,

    Can you please confirm you setup/install steps?

    I have the same A101D Sangoma card and running Elastix 1.3-2 trying to connect to an E1 Telco in New Zealand, and I followed your step and got a different result.

    For example, If you run "setup-sangoma" first then do the "detect new hardware" step, it will over write the "setup-sangoma" files.

    Can you please confirm which files are modified? I have the following files,

    1. /etc/zaptel.conf

    # Autogenerated by /usr/local/sbin/sangoma/setup-sangoma -- do not hand edit
    # Zaptel Channels Configurations (zaptel.conf)
    #
    loadzone=us
    defaultzone=us

    #Sangoma A101 port 1 [slot:4 bus:11 span:1] <wanpipe1>
    span=1,0,0,ccs,hdb3,crc4
    bchan=1-15,17-31
    hardhdlc=16

    2. /etc/wanpipe/wanpipe1.conf

    #================================================
    # WANPIPE1 Configuration File
    #================================================
    #
    # Date: Wed Dec 6 20:29:03 UTC 2006
    #
    # Note: This file was generated automatically
    # by /usr/local/sbin/setup-sangoma program.
    #
    # If you want to edit this file, it is
    # recommended that you use wancfg program
    # to do so.
    #================================================
    # Sangoma Technologies Inc.
    #================================================

    [devices]
    wanpipe1 = WAN_AFT_TE1, Comment

    [interfaces]
    w1g1 = wanpipe1, , TDM_VOICE, Comment

    [wanpipe1]
    CARD_TYPE = AFT
    S514CPU = A
    CommPort = PRI
    AUTO_PCISLOT = NO
    PCISLOT = 4
    PCIBUS = 11
    FE_MEDIA = E1
    FE_LCODE = HDB3
    FE_FRAME = CRC4
    FE_LINE = 1
    TE_CLOCK = NORMAL
    TE_REF_CLOCK = 0
    TE_SIG_MODE = CCS
    TE_HIGHIMPEDANCE = NO
    LBO = 120OH
    FE_TXTRISTATE = NO
    MTU = 1500
    UDPPORT = 9000
    TTL = 255
    IGNORE_FRONT_END = NO
    TDMV_SPAN = 1
    TDMV_DCHAN = 16
    TDMV_HW_DTMF = NO

    [w1g1]
    ACTIVE_CH = ALL
    TDMV_ECHO_OFF = NO
    TDMV_HWEC = YES

    3. /etc/asterisk/zaptel.conf.wanpipe,

    ; Autogenerated by /usr/local/sbin/sangoma/setup-sangoma -- do not hand edit
    ; Zaptel Channels Configurations (zapata.conf)
    ;
    ; This is not intended to be a complete zapata.conf. Rather, it is intended
    ; to be #include-d by /etc/zapata.conf that will include the global settings
    ;
    callerid=asreceived

    ;Sangoma A101 port 1 [slot:4 bus:11 span:1] <wanpipe1>
    switchtype=euroisdn
    context=from-zaptel
    group=0
    signalling=pri_cpe
    channel =>1-15,17-31

    I don't think I use /etc/asterisk/zapata.conf file at all.

    I also don't have the "dahdi", "zap" and "pri" commands available via the Asterisk CLI. Is this a major problem?

    I have also done a "yum update" and a FreePBX update to 2.4.1.2.

    Thanks
     
  7. my898

    Joined:
    Jan 6, 2009
    Messages:
    7
    Likes Received:
    0
    Hi,

    I have fixed my Primary Rate D-Channel lock-out alarm on the Telco end.

    I needed to configure my /etc/asterisk/zapata.conf file correctly and reboot the server. Also that my server DID NOT include ANY updates with "yum" as suggested by Bob. I might give "yum" ago after my pilot project is done just to see if it works or not.

    The reason why I had trouble was when I used "setup-sangoma" it created the files /etc/zaptel.conf, /etc/wanpipe1.conf and /etc/asterisk/zapata.conf.wanpipe so I thought I had to modify the "zapata.conf.wanpipe" file to get my Primary Rate going. Since a lot of stuff on the web indicated "zapata.conf" and not "zapata.conf.wanpipe" and after daily re-building of the server I finally modified the "zapata.conf" and things started to move again.

    So my final config files are,

    1. /etc/zaptel.conf,

    # Autogenerated by /usr/local/sbin/sangoma/setup-sangoma -- do not hand edit
    # Zaptel Channels Configurations (zaptel.conf)
    #
    loadzone=nz
    defaultzone=nz

    #Sangoma A101 port 1 [slot:4 bus:11 span:1] <wanpipe1>
    span=1,0,0,ccs,hdb3,crc4
    bchan=1-10
    hardhdlc=16

    2. /etc/asterisk/zapata.conf

    [trunkgroups]

    [channels]
    context=default
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=yes
    faxdetect=incoming
    echotraining=800
    rxgain=0.0
    txgain=0.0
    group=0
    callgroup=1
    pickupgroup=1

    pridialplan=unknown
    prilocaldialplan=unknown
    overlapdial=yes

    ;Uncomment these lines if you have problems with the disconection of your analog lines
    ;busydetect=yes
    ;busycount=3


    immediate=no

    ;Sangoma A101 port 1 [slot:4 bus:11 span:1] <wanpipe1>
    switchtype=euroisdn
    context=from-zaptel
    group=0
    signalling=pri_cpe
    channel => 1-10

    #include zapata_additional.conf
    #include zapata-channels.conf

    /etc/wanpipe/wanpipe1.conf

    #================================================
    # WANPIPE1 Configuration File
    #================================================
    #
    # Date: Wed Dec 6 20:29:03 UTC 2006
    #
    # Note: This file was generated automatically
    # by /usr/local/sbin/setup-sangoma program.
    #
    # If you want to edit this file, it is
    # recommended that you use wancfg program
    # to do so.
    #================================================
    # Sangoma Technologies Inc.
    #================================================

    [devices]
    wanpipe1 = WAN_AFT_TE1, Comment

    [interfaces]
    w1g1 = wanpipe1, , TDM_VOICE, Comment

    [wanpipe1]
    CARD_TYPE = AFT
    S514CPU = A
    CommPort = PRI
    AUTO_PCISLOT = NO
    PCISLOT = 4
    PCIBUS = 11
    FE_MEDIA = E1
    FE_LCODE = HDB3
    FE_FRAME = CRC4
    FE_LINE = 1
    TE_CLOCK = NORMAL
    TE_REF_CLOCK = 0
    TE_SIG_MODE = CCS
    TE_HIGHIMPEDANCE = NO
    LBO = 120OH
    FE_TXTRISTATE = NO
    MTU = 1500
    UDPPORT = 9000
    TTL = 255
    IGNORE_FRONT_END = NO
    TDMV_SPAN = 1
    TDMV_DCHAN = 16
    TDMV_HW_DTMF = NO

    [w1g1]
    ACTIVE_CH = ALL
    TDMV_ECHO_OFF = NO
    TDMV_HWEC = YES

    Hope this helps someone else.

    Cheers
     

Share This Page