0.8.5b / mISDN / Aastra 55i

Gadge

Joined
Aug 17, 2007
Messages
3
Likes
0
Points
0
#1
I have a strange problem that is driving me nuts.

I am using Elastix 0.8.5b with a Digium B410p ISDN card with the mISDN drivers. I have the everything working however the voice quality presented to the internal sip handset user when the call is to a PSTN connection is poor. The quality presented to the PSTN target is good.

LED on the B410p is red but when a call is active is green.

My ISDN line is in the UK provisioned by BT and is ptmp.

The process that I have followed to get this working is:

1) Copy the following to the freshly built system:
kernel-devel
mISDN-1_1_5
mISDNuser-1_1_5
asterisk 1.4.10.1

2) RPM install the kernel-devel

3) make && make install of mISDN

4) make && make install of mISDNuser

5) make clean && ./configure && make && make install on Asterisk

6) /etc/init.d/misdn-init config

7) edit /etc/misdn-init.cfg and /etc/asterisk/misdn.cfg

To make the above take effect I do "amportal stop" then "/etc/init.d/misdn-init start" then "amportal start"

I add the custom route for mISDN in FreePBX and point an any/any DDI rule to the Aastra 55i handset.

Inbound and outbound calls work but the user on the Aastra 55i hears poor quality from the connected PSTN user. The PSTN user get good quality.
Internet SIP to SIP is also good quality.

Below is what I have already tried to sort this:-

1) Tried on two different machines
2) updated / down graded mISDN
3) tried recompiled kernel with 250 timing
4) Tested ISDN line with other kit and its fine
5) Tried with Asterisk 1.2 and it was OK but mISDN caused kernel panics
6) Everything looks OK within Asterisk
7) Have tried on Elastix 0.8.5a
8) tried disabling echo cancellation on the b410p
9) tried disabling jitterbuffer both in SIP config on Asterisk and on the b410p and combinations of both

What it intend trying next is :-

1) Using a Polycom handset
2) Down grading the kernel version
3) Try the whole process on Elastix 0.8.4

Below are the config files for mISDN :-

/etc/misdn-init.cfg

card=1,0x4
te_ptmp=1
option=1,master_clock
poll=128
dsp_options=0
debug=0xf

/etc/asterisk/misdn.cfg

[general]
misdn_init=/etc/misdn-init.conf
debug=0
ntdebugflags=0
ntdebugfile=/var/log/misdn-nt.log
bridging=no
l1watcher_timeout=0
stop_tone_after_first_digit=yes
append_digits2exten=yes
dynamic_crypt=no
crypt_prefix=**
crypt_keys=test,muh

[default]

context=from-pstn
language=en
musicclass=default
senddtmf=yes
far_alerting=no
allowed_bearers=all
nationalprefix=0
internationalprefix=00
rxgain=0
txgain=0
te_choose_channel=no
pmp_l1_check=no
pp_l2_check=no
reject_cause=16
need_more_infos=no
nttimeout=no
method=standard
dialplan=0
localdialplan=0
cpndialplan=0
early_bconnect=yes
incoming_early_audio=no
nodialtone=no
presentation=-1
screen=-1
echocancel=yes
echocancelwhenbridged=no
echotraining=no
jitterbuffer=4000
jitterbuffer_upper_threshold=0
hdlc=no
max_incoming=-1
max_outgoing=-1

[out]
ports=1
context=from-pstn
msns=*

Does anyone have any ideas ?
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top